在 Ubuntu 9.10 下安装和简单配置 trac 0.12dev

昨日(2010-03-14)在金山参加了”CPyUG会课总第38期~暨珠三角技术沙龙第6次“。会中廖杰大仙用平和的语气,激动人心的介绍了 trac 若干功能、以及插件的开发和金山已经在使用的或者准备使用的插件。回来手痒,随尝试安装 0.12dev。

关于 Windows 下的安装,请看赖神的《在 windows 下安装和简单配置 trac 0.12》。

Ubuntu 下没 Windows 下麻烦,不过如果完全按照 Trac 官方的文档,还是会略有折腾,特别记录于此,以备后用。

# 安装 ubuntu 提供的库,能由 apt 管理的包,还是交由 apt 管理
sudo apt-get install subversion
sudo apt-get install python-setuptools
sudo apt-get install sqlite3
sudo apt-get install python-pysqlite2
sudo apt-get install python-pygments
sudo apt-get install python-docutils
# 下面的包,不是 ubuntu 没有提供 apt 源,就是源里的版本过旧。所以使用 easy_install 安装最新稳定版。
sudo easy_install pytz
sudo easy_install babel
# Genshi 甚至 stable 版本都不行,所以使用 dev,也就是 svn 中的版本。不过安装好后需要手工做一下处理。
sudo easy_install -U "Genshi==dev"
# 进入 egg 存放目录
cd /usr/local/lib/python2.6/dist-packages/
# 修改刚才通过 easy_install 安装的 Genshi 的 egg 版本,也许是我哪里没搞合适,用 easy_install 安装 svn 的版本,版本号默认总是 0。
# 本来,版本只要大于 1072 即可,不过为了避免弄混,所以还是用版本库中的真实版本号为好。我安装的时候,genshi 的版本号是 1096。
mv Genshi-0.6dev_r0-py2.6.egg Genshi-0.6dev_r1096-py2.6.egg
# 同时需要修改 easy-install.pth 中的 genshi 的 egg 文件名
sudo vim easy-install.pth

在 easy-install.pth 中找到 ./Genshi-0.6dev_r0-py2.6.egg,将这个文件名修改为对应的正确的版本号的文件名。

# 然后安装 Trac 的 svn 主线版本。当前,也就是现在的里程碑 0.12dev
sudo easy_install http://svn.edgewall.org/repos/trac/trunk

至此,trac 0.12dev 版本安装完毕。
0.12dev 跟之前的版本有些变化的是,在用 trac-admin 创建 trac 环境的时候,不会再询问代码仓库的路径。也就是说,可以在 trac 中完全屏蔽代码管理的功能。

详细的内容可以看 http://trac.edgewall.org/wiki/0.12/TracRepositoryAdmin

另外,必装插件 http://trac-hacks.org/wiki/AccountManagerPlugin

好吧,如同往日一样,我总是最后才爆点猛料出来:Ubuntu 下的打包好的安装文件——舒放任务通道 http://py.kingsoft.net/ktrac/wiki/KtracInstall

特别感谢 KingSoft、感谢Z.Q.大妈、感谢廖杰……oh,md,我错了,先要感谢祖国-_-!

2 thoughts on “在 Ubuntu 9.10 下安装和简单配置 trac 0.12dev”

Leave a Reply

Your email address will not be published. Required fields are marked *