RatProxy 在 cygwin 下的编译

ubuntu 下已经搞掂,很简单:apt-get install make gcc build-essential libssl-dev ca-certificates,然后 make 即可。

cygwin 下有一点小麻烦,特别记录一下:

需要安装的包:make gcc binutils openssl-devel

需要做的改动:Makefile 的 CFLAGS = -Wall -O3 -Wno-pointer-sign -D_GNU_SOURCE 改为 CFLAGS = -Wall -O3 -D_GNU_SOURCE,去掉 -Wno-pointer-sign。否则会有一个不支持参数 xxxx 的报错。

然后一样,make 即可。

Leave a Reply

Your email address will not be published. Required fields are marked *