关于 QQ OAuth 封装出现 T_PAAMAYIM_NEKUDOTAYIM 的解决办法

许多网友在使用我的 OAuth 的腾讯微博封装(腾讯微博开放平台的PECL的OAuth封装)时都遇到了 T_PAAMAYIM_NEKUDOTAYIM 的错误。为了方便大家,干脆这里统一说明一下吧。

这个错误的责任在我。
由于我使用的开发和部署环境都是 Ubuntu 环境,PHP 版本 5.3.3。我在编码的时候使用了一个 5.2.x 不支持的特性。在 XY/QQ/Store.php 的 28 行:

<br />
$class::setParams($params);<br />

经不完全验证在 5.2.x 及以下版本会报 T_PAAMAYIM_NEKUDOTAYIM 错误。

解决办法其实很简单,将 28 行代码替换为:

<br />
call_user_func(array($class, 'setParams'), $params);<br />

仅此即可。

真是抱歉了!同时感谢 ahusjolzy 提供的关键信息!

One thought on “关于 QQ OAuth 封装出现 T_PAAMAYIM_NEKUDOTAYIM 的解决办法”

Leave a Reply

Your email address will not be published. Required fields are marked *